We've Moved!

  • As of Monday, April 23, 2012 this system has become read-only!
  • As activity picks up on our new support and forums this site will be closed down.
  • If you have any outstanding support issues in this system we will still answer them here until they are resolved!

Need Support?

New Forums!

  • If you have any great suggestions or topics you want to discuss please do so at forums.nirvanahq.com

Recurring/Focus Problem Identified, Fix in progress

David McLaughlin's Avatar

David McLaughlin

04 Jan, 2012 01:36 AM

Short version...
We have identified the issue with problems described in the posts:
http://help.nirvanahq.com/discussions/problems/1350-build-358-recur...
and
http://help.nirvanahq.com/discussions/problems/1366-tasks-due-today...

Expect to push out a fix release in the next day or two.

A bit of historical background...

With the last release we moved calculation and generation of recurring tasks, moving Scheduled & Due tasks to Focus, etc. from the browser/device to the Nirvana servers.

The reason for this is basically that there was a stale data problem that we couldn't control without essentially hijacking your devices, requiring plugins, or allowing some other bad things to occur. The typical scenario was that someone would leave N2 logged in on a browser, close it without signing out (which clears the local storage), and then comes back 2 months later, and opens N2. At that time an out-dated version of the app was likely in the stale device and the app and data on the device would start 'catching up' by moving old items to Focus, spawning recurring tasks that would then update to the server and other devices, etc. An overly simplified explanation, but I'm sure you get the idea.

So we moved the core logic to the server (with a little bit of logic on the client device for working in a disconnected mode).
On the server, every hour a job runs that selects those accounts that are in a 'new' day based on your time zone, and processes the routines for that segment of users. Under certain circumstances that process aborted and the 'downstream' users' data wasn't auto-updated as to moving Scheduled tasks to Focus, etc.

Normally, you'd expect the Refresh button to resolve that, and it should have, but its logic didn't get changed to reflect the changes made to the server side timing (it will in the fix release), and so it was ineffective in correcting the original issue - oh joy.

So much for the bugs & fixes, but there is one behavioral change that people need to be aware of.
If you leave your browser open, with N2 active, overnight you will need to do a page refresh (Ctrl-F5) or use the Refresh button (after the fix) to invoke a server access to get the changes sent to your browser/device. If you close the N2 browser tab/window, regardless of whether you logout or not, you won't need to do that since the server is accessed on app 'startup'.

Let me know if you have any questions.

Thanks,
David

  1. 2 Posted by Phil on 04 Jan, 2012 02:15 AM

    Phil's Avatar

    Thanks for the update, David. Glad to hear you guys were able to get it figured out. I, and I'm sure others, will let you know how it works once it rolls out.

    Cheers

  2. 3 Posted by robmutsaars on 04 Jan, 2012 08:54 AM

    robmutsaars's Avatar

    Thanks for the explanation David. Clear feedback. Will wait for the fix and then feedback to you

    Thanks,

    Rob

  3. 4 Posted by Kenny Grant on 04 Jan, 2012 10:48 AM

    Kenny Grant's Avatar

    Thanks David

  4. 5 Posted by torstenkoepke on 11 Jan, 2012 06:07 PM

    torstenkoepke's Avatar

    @David I know from my own code developing work that 'one or two days' can be quite long. Am I guessing right that you are still working on the fix release?
    Regards - Torsten

  5. Support Staff 6 Posted by David McLaughlin on 12 Jan, 2012 05:19 PM

    David McLaughlin's Avatar

    @torstenkoepke -- The problem being in a 3rd-party lib is that the expected simple fix (2 actually) that should have worked didn't.

    For the 'real' fix, we have to do a fair bit of code refactoring (and setup of a new test environment to validate without mucking up production or our existing test setup) to get around the problem so it's taking longer than originally expected.

    David

  6. 7 Posted by torstenkoepke on 12 Jan, 2012 05:42 PM

    torstenkoepke's Avatar

    Thanks David.

  7. 8 Posted by Phil on 16 Jan, 2012 04:38 PM

    Phil's Avatar

    I am noticing some problems again under the latest build (379). I have scheduled tasks that are due today but have not been moved into focus. At the same time, I am not seeing the update focus button.

  8. Support Staff 9 Posted by David McLaughlin on 17 Jan, 2012 02:20 PM

    David McLaughlin's Avatar

    Elbert put in the fix last night/this morning - see the blog post...
    http://blog.nirvanahq.com/2012/01/17/fixings-to-memory-overruns/

    As mentioned there may be a one-time "miss" for people in the time zones listed in the blog post. Either do a refresh or click on the "button" as mentioned.

    David

  9. 10 Posted by robmutsaars on 19 Jan, 2012 07:37 AM

    robmutsaars's Avatar

    Hello - i doubt whether this fix has actually solved the issue (for me). i still get to see the 'bring to focus' button every morning. I logout / login every morning, refreshed several times (actually i refresh every morning, just to be sure there is nothing in the cache) but still my tasks are not automatically moved to 'focus'.
    Is this issue supposed to be solved or am i totally missing the point :-)

    Rob

  10. 11 Posted by Geert on 19 Jan, 2012 10:10 AM

    Geert's Avatar

    Same here ...

    I live in the GMT+1 timezone, and yesterday and today the 'bring to focus' button was visible. When I click it, Focus gets updated with the tasks that should come into Focus.

    I shut down my computer at night, so there's no being logged on overnight.

  11. Support Staff 12 Posted by Elbert McLaughlin on 20 Jan, 2012 06:28 AM

    Elbert McLaughlin's Avatar

    UPDATE: users in timezones where we have ~10,000 user accounts or more (GMT+1, GMT-5...) are still experiencing issues. turns out it's our inefficient processing of millions of rows of n1 user data that's causing the hiccups. anyway.... solution is near.

  12. 13 Posted by Mark S on 20 Jan, 2012 02:21 PM

    Mark S's Avatar

    Thanks for the update Elbert, I was just coming on to post that this was still an issue for me.
    I'm in GMT-5 so I'll just sit tight.

    Thanks again,
    Mark

  13. Support Staff 14 Posted by Elbert McLaughlin on 23 Jan, 2012 12:30 PM

    Elbert McLaughlin's Avatar

    So far so good, as far as memory management is concerned. We switched from a single process that tried to process all tasks for users in each timezone, to a queueing system that processes each user account individually, and we haven't seen any memory related errors since. Knock on wood, I think we can put this one to rest (and move on to other bugs now). :-P

  14. 15 Posted by Phil on 24 Jan, 2012 01:28 PM

    Phil's Avatar

    I am noticing this problem again this morning. I have scheduled tasks that are due today but have not been moved into focus. At the same time, I am not seeing the update focus button.

    I am in eastern time zone US and running the latest build, 389. Neither refreshing the app nor the browser resolves the issue.

  15. 16 Posted by david-drake on 24 Jan, 2012 06:55 PM

    david-drake's Avatar

    Okay -- now I am seeing tasks in the focus list that I have completed and moved to the logbook appear as if they have not done when accessing from another computer,or the mobile site on my iPad. Restarting has not helped, nor has refreshing. I have not tried logging out and then coming back on -- will do that now...

  16. 17 Posted by david-drake on 24 Jan, 2012 06:57 PM

    david-drake's Avatar

    Update -- logging out and then logging back in got my iPad up to date.

    -David

  17. 18 Posted by david-drake on 24 Jan, 2012 09:11 PM

    david-drake's Avatar

    I forgot to mention....the task that was in the focus list was a scheduled one. It came into the focus list okay on the scheduled date, but clicking it complete would not synch to my other office computer, my iPad, or iPhone. Logging off and logging back one each one of them got things back in synch.

    Just trying to help....

    -David

  18. Support Staff 19 Posted by Elbert McLaughlin on 24 Jan, 2012 10:42 PM

    Elbert McLaughlin's Avatar

    Just rolled a fix for this.

    FYI, data has been posting to the cloud just fine, but Build 389 wasn't reflecting changes from the cloud properly. Bug in timestamp comparison. Totally my fault. Sorry!

    Please logout, refresh... wait... refresh, and when you see Build 390 log back in.

  19. 20 Posted by peter.nistelberger on 23 Feb, 2012 02:54 PM

    peter.nistelberger's Avatar

    Hi guys,

    I am sorry but I am still experiencing this problem.
    I use Nirvana N2 Build 391 with Firefox on Windows Vista and my recurring tasks are not moved to Next/Focus. It only works after I force a reset with this link: https://app.nirvanahq.com/reset .

    I came back to Nirvana after not using it for several months. Maybe that helps.

  20. Support Staff 21 Posted by David McLaughlin on 23 Feb, 2012 05:16 PM

    David McLaughlin's Avatar

    You needed to do a logout-login to get a fix as mentioned in thisblog post....
    http://blog.nirvanahq.com/2012/01/24/builds-389-and-390/

    You need to do that (or a reset, which forces a logout) for each device/browser combination you used.

    It's a one-time thing (for each combo; FF, Chrome, etc).

    dbm

  21. 22 Posted by robmutsaars on 27 Feb, 2012 09:01 PM

    robmutsaars's Avatar

    Hi guys,

    I thought i got rid of the button - at least i believe it was not there for some weeks (did not use Nirvana that frequently). But this week the issue reappeared.

    i am logging out of Nirvana every day, closing my browser and relogging in the next morning. And the button is there again :-(

  22. 23 Posted by Geert on 28 Feb, 2012 08:19 AM

    Geert's Avatar

    I noticed the button too in the last few days (including this morning).

  23. 24 Posted by peter.nistelberger on 28 Feb, 2012 08:33 AM

    peter.nistelberger's Avatar

    Hi David, hi guys,

    I am sorry. I've done the logout-login part on all device/browser combinations I can remember for using with Nirvana but my scheduled tasks are still not moved to Next on the scheduled date. However, I now see the button 'Move Scheduled Items Into Place Now' every day. I have changed one of my devices in the last months and I have done a complete set-up with one other. That means, it is not possible for me to login/logout on each device I have ever used with Nirvana. Can that be part of the Problem?
    Regards, Peter

  24. 25 Posted by robmutsaars on 28 Feb, 2012 02:57 PM

    robmutsaars's Avatar

    I did this logout-login several times but the button reappears.

  25. 26 Posted by Josema on 02 Mar, 2012 11:47 AM

    Josema's Avatar

    I'm on b391 and still experiencing this issue; has it been fixed already? And if so, has it been applied to existing tasks?

  26. 27 Posted by Josema on 02 Mar, 2012 11:51 AM

    Josema's Avatar

    update: the /reset method above worked for me (Chrome 17 on OSX Lion)

  27. Support Staff 28 Posted by David McLaughlin on 07 Mar, 2012 03:25 PM

    David McLaughlin's Avatar

    FYI, people I'm closing this thread because it's straying from the original issue.

    In closing, there are valid and expected scenarios for the "Move Sched" button to occur on occassion -- but having to use it every day really should not be necessary.

    That said, if you are having to use if every day, or very frequently, there may be an edge case scenario we need to look at -- but I can't do that without specific information that I don't think you want to make public.

    So if you want me to look at your situation, I need to have you open a private support discussion so I can get more information.

    Thanks,
    David

  28. David McLaughlin closed this discussion on 07 Mar, 2012 03:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

01 Sep, 2014 06:48 PM
14 Aug, 2014 03:14 AM
01 Aug, 2014 09:51 AM
01 Aug, 2014 02:01 AM
19 May, 2014 10:31 PM